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This article introduces a simple, inexpensive, and portable
image-based technique for nondestructive leaf area
measurements (Figure 1). It uses an imaging apparatus
made with ordinary office supplies to obtain leaf images

in greenhouse or field environments. Leaf images are then
processed and analyzed to measure leaf area using Image],
an open-source image processing program. Because both
image capture and analysis are performed nondestructively,
leaf area can be measured on the same leaf repeatedly,
enabling the monitoring of leaf growth over time. Leaf
area data can also be used to assess leaf or whole-canopy
physiology by converting the unit of other nondestructive
measurements, such as photosynthesis and transpiration,
from per-unit leaf area to per leaf. This technique is particu-
larly useful to researchers and students studying leaf growth
and physiology in greenhouse or field environments. This
article is part of a series introducing various image-based
measurements for horticultural research. The tutorial video
for this article is available at the UF IFAS Horticultural
Crop Physiology Lab YouTube channel (https://youtu. e e IR AR
be/5]hH9-WosgA). Other Image] tutorial videos are also Figure 1. Capturing a pepper leaf image nondestructively in the field.

Thei in this ph h'is described in Fi 3.
available at https://www.youtube.com/playlist?list=PL4qrj;3 € Image apparatus in this photograph is described in Figure
jZ61568ToiUV-DvAsQOGyb30hK. Introduction

Leaf area is an important horticultural trait that reflects
plant health, growth, and environmental stress (Gonzalez
et al. 2010). Leaf area data can also convert the unit of other
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measurements, such as photosynthesis and transpiration,
from per-unit leaf area to per leaf, enabling the assessment
of leaf or whole-canopy physiology.

Leaf area can be measured destructively or nondestruc-
tively. Traditional techniques such as grid count, paper
weighing, and planimeter methods (Chaudhary et al. 2012;
Montero et al. 2000) are rarely used in current horticultural
research because of the time-consuming measurement
processes. More modern techniques involve imaging leaves
by scanners or cameras, followed by optical measurements
or image analysis (Easlon and Bloom 2014). Various types
of commercial leaf scanners are available. Stationary scan-
ners with conveyor belts are used for destructive measure-
ments, whereas portable palette- or wand-style scanners
are used for nondestructive measurements. Their optical
measurements are highly accurate. The major drawback of
leaf scanners is their high instrument cost.

This article introduces a simple, inexpensive, and portable
image-based technique for nondestructive leaf area mea-
surements (Figure 1). The imaging apparatus is made with
ordinary office supplies and designed to easily obtain leaf
images in greenhouse or field environments. Leaf images
are then processed and analyzed to measure leaf area using
Image], an open-source image processing program. The
advantages and disadvantages of this technique are as
follows:

Advantages

o The apparatus only requires inexpensive, ordinary office
supplies. Also, Image] is a public domain program, and it
is free to download.

o The image processing and analysis is quick—typically 1.5
to 2 minutes per image.

o The apparatus is portable and produces acceptable image
quality for image analysis under many different environ-
mental conditions (Figure 2).

o Measurements can be performed on the same leaf repeat-
edly, making it possible to monitor leaf growth over time.

 Images themselves are very good visual data.

« Photographs can be saved with metadata, such as geolo-
cation, date, and time, automatically.

Disadvantages

o Leaf area measurements involve two separate steps: image
acquisition and image analysis. Data cannot be obtained
until images are analyzed.

o Using Image] for image processing and analysis requires
some basic computer literacy and installation of a

compatible version of Java software (https://www.java.
com/ES/download/).
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Figure 2. Hop leaf images successfully processed with ImageJ under
three different weather and lighting conditions.

Taking Photographs
Imaging Apparatus

The imaging apparatus for capturing leaf images nonde-
structively is shown in Figure 3. It is assembled using the
following items:

o Cellphone or digital camera x 1

« Red clipboard x 1

Clear folder pocket x 1

o Magnets x 2

« Binder clips x 2

o Post-it (in this case 3 inches) x 1
3" Post-it

Magnet Binder clips
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Figure 3. The imaging apparatus for capturing leaf images
nondestructively. Left: A clear folder pocket with a magnet on each
plastic sheet and a 3 inch Post-it inside. Right: A fully assembled
apparatus. The upper-left binder clip should be clipped to the
clipboard and the top sheet of the clear folder pocket. The upper-right
binder clip should be clipped to the clipboard and the bottom sheet
of the clear folder pocket.
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Note: Note:

o The leaf can slide out because it is held loosely by the
imaging apparatus. Hold the apparatus still until image
capture is complete.

o During the testing phase for this technique, different
clipboard colors (e.g., white, red, black, brown) were
used. We found that image processing was most success-
ful when the red clipboard was used, probably because

. , 4. Take a picture.
red is green’s complementary color.

Image Capture Protocol

1.On the clear folder pocket, detach the magnet on the top
sheet from the bottom sheet.

Note:

o Make sure the clipboard is perpendicular to the camera
and all the corners are squared off. This ensures the scaled
Post-it is the same focal distance from the camera as the
leaf, and leaf area is not distorted by clipboard tilt.

« Choose an overcast day, or a camera angle that can mini-
mize deep shadows in the image (e.g., a sunny day with
no clouds at 12-2 p.m. for overhead plot photographs).

« Short of blinding glare, light reflection on the imaging
apparatus will not affect image analysis.

Download ImagelJ Software
1.Go to https://imagej.nih.gov/ij/ and select “Download.”

3.Reattach the magnets so the top sheet of the clear folder 2. Determine your platform (Mac/Linux/Windows) and
pocket is smooth and flattens the leaf. click on the appropriate link.

3.Install the program. The measurements described below
do not require plugins.

Note:

« Another download option is Fiji (https://imagej.net/Fiji/
Downloads), a version of Image] bundled with many
plugins.
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Image Processing and Analysis

This example will use a photograph of a pepper leaf taken
in the field. The photograph was taken using an iPhone 7 in
the middle of a sunny day.

Step 1: Set Scale (Spatial Calibration)

1.Import the image: Go to “File > Open” and navigate to
the image or drag the file onto the Image] toolbar.

o . 2020-E52020-06-04.14.0RG (16.7%)
pixels; RGB; 47MB

2.Select the “Straight Line” tool (highlighted below).

L Imsge y
oo 4N Alale] | Qs s | |=»
“Ltraight®, segmented or freehand lines, or armows (right click to swit...

3.Draw a line to an object of known size (e.g., Post-it).

o0 e 2020-E6_2020-06-04_14.JPG (16.7%)
13.71x10.29 inches (4032x3024) RCB; 47MB

Note:
« The image can also be scaled by the clipboard.

4.Go to “Analyze > Set Scale” to set the distance to the line.

i. Enter the following parameters (e.g., Post-it size = 3
inches).

o Known distance: 3
« Unit of length: inch
o Global: Unchecked

e @ Sel Scale

Distance in pixels: 882
Known distance: 3
Pixel aspect ratio: 1.0

Unit of length: | inchl
Click to Remove Scale
Global
Scale: 294 pixels /inch

Help Cancel oK

ii. Click on “OK”

Note:

« When the “Global” option is checked, the same image
calibration will be applied to images that will be imported
subsequently. Use this option when the same image needs
to be imported multiple times to perform different sets of
image analysis or when all images in a set have the same
scale. When working on an image with a different scale,
“Set Scale” must be done again.

Step 2: Cropping the Image

1. Use the “Rectangle” tool to select the area of interest.

i. Click the “Rectangle” tool (highlighted below).
® - . Imaga. ; ;

B ocio~4s|alala]l |qlmws]s|s] | |»
Rectangle®, rounded rect or rotated rect (right click to switch)

ii. Select the smallest rectangle possible around the leaf.

[ XX ] 2020-£5_2020-06-04_14.JPG (16.7%)
13.71x10.29 inches (4032x3024); RGB; 47MB

2.Go to “Image > Crop” to crop the image.
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Note:

« The magnet should be excluded from the cropped image
because its hue and brightness are similar to those of
the leaf. If it is impossible to exclude the magnet with
the “Rectangle” tool, use the “Freehand selections” tool
instead.
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Step 3: Color Thresholding
1.Go to “Image > Adjust > Color Threshold” to separate the
leaf from the background.

i. Adjust color threshold parameters (hue, saturation, and
brightness) to select the leaf.

Note:

o Hue is one of the color appearance parameters, and it
describes pure spectrum colors. Because red is green’s
complementary color, it is relatively easy to separate one
from the other.

o In this case, hue range from 40 to 185, saturation from 0

B Pass

145

& Pass

Saturatbon
o

o
| 175
Threshalding method:  Default B
Threshold color: Red B
Color space:  HSE B

B Dark background
|
| Original

Filtened Select Sample

Stack Macra Help
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ii. Click on “Select”

2.Go to “Process > Binary > Make Binary” to convert the
color image to a binary (black and white) image.

[ean 203085, 3010-06-04. 1495 75%
| 5220261 inghes (153647600 LT LAk

Step 4: Leaf Area Measurement

1.Go to “Analyze > Set Measurements” to select measure-
ment variables.

i. Select “Area” and “Limit to threshold”

ii.Click on “OK”

) Set Measurements
: Ares Miean gray value
Standard deviation Modal gray value
Min & max gray value Centroid
Center of mass Perimeter
Bounding rectangle Fit ellipse
Shape descriptors Feret's diamater
Integrated deniity Median
Shewneis Eunosis
Area fraction Stack position

| E Limit to threshold
Inwernt ¥ coprdinates
Add 1o overlay

Display label
Scientific natatian
NaN empty cells

Mome B

Redinect to:

| Decimal places (0-9): 3

Help Cancel LE

2.Go to “Analyze > Measure” or Ctrl+M to measure the leaf
area.



Leaf Area Estimation Accuracy

The accuracy of this technique was compared to the
LI-3100C Area Meter (LI-COR, Lincoln, NE), which is one
of the most commonly used instruments for destructive
leaf area measurements. This instrument is equipped with
two transparent conveyer belts that rotate to move leaves
across a scanning bed, where light obstruction is measured
to compute leaf area (Figure 4). The maximum resolution of
leaf area measurements by this instrument is 0.1 mm?®.

Figure 4. LI-3100C Area Meter (LI-COR, Lincoln, NE).

Leaf area was measured on 100 hop leaves and 100 pepper
leaves by the LI-3100C Area Meter and the technique
outlined above. The data were fit to a simple linear regres-
sion model: y = ax + b (Figure 5). For both crops, the
correlations were nearly 1:1 with extremely high r* values,
demonstrating the high accuracy of the nondestructive leaf
area measurement technique described in this article.
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Leaf area measured by ImageJ (cm?)
Figure 5. Linear regression analysis for 100 hop leaves (left) and 100
pepper leaves (right) between leaf area measured by the image
analysis with ImageJ and by the LI-3100C leaf area scanner.
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Other Image-Based Measurements

With the line tool in Image], other leaf morphological traits,
such as leaf length and width, can also be measured from
the images collected by this method (Agehara 2020).
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