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This article introduces simple image processing and analysis 
techniques to quantify leaf disease damage using ImageJ, an 
open-source image processing program (Figure 1). These 
techniques are not meant to replace crop scouting or dis-
ease diagnosis by a plant diagnostic laboratory, but rather 
to provide a supplemental tool for making quantitative 
measurements of leaf disease damage. Similar techniques 
are also available for plant growth assessment, including 
plant height, plant width, and canopy cover area (Agehara 
2020). The image processing and analysis techniques 
introduced in this article are fairly simple to use and thus 
can be adopted not only by researchers, but also by crop 
consultants, Extension agents, and students. Tutorial videos 
are also available at the UF IFAS Horticultural Crop Physi-
ology Lab YouTube channel (https://www.youtube.com/pla
ylist?list=PL4qrjj3jZ6i568ToiUV-DvAsQ0Gyb30hK).

Introduction
Plant diseases can cause many types of symptoms. Each 
disease has characteristic symptoms, such as leaf spots, 
chlorosis, necrosis, stunting, wilting, and other deformities. 
Although symptoms can be exhibited by the entire plant 
or by a specific organ of the plant, many common diseases 
cause symptoms on leaves.

Image-based techniques can perform quantitative measure-
ments that are generally more objective, accurate, and 
repeatable than visual scoring (Laflamme et al. 2016; Mutka 
and Bart 2015; Sibiya and Sumbwanyambe 2019; Xie et al. 
2012). This article introduces simple image processing and 
analysis techniques to quantify leaf disease damage using 
ImageJ, an open-source image processing program. In the 
following sections, we will demonstrate different techniques 
step by step using the following plant diseases as examples: 
Phomopsis leaf blight on blackberry, downy mildew on 
cucumber, and bacterial leaf spot on tomato. We will also 
demonstrate some troubleshooting techniques to process 
nonideal images. The advantages and disadvantages of 

Figure 1. An example of image processing techniques for image-based 
quantification of leaf disease damage using ImageJ.

https://edis.ifas.ufl.edu
https://www.youtube.com/playlist?list=PL4qrjj3jZ6i568ToiUV-DvAsQ0Gyb30hK
https://www.youtube.com/playlist?list=PL4qrjj3jZ6i568ToiUV-DvAsQ0Gyb30hK
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image-based quantification of leaf disease damage are as 
follows:

Advantages
• Image-based measurements provide quantitative data and 

can be more objective and accurate than visual scoring.

• Cost and tools needed are minimal—you only need an 
image-capturing device (digital camera, smartphone, or 
flatbed scanner) and ImageJ.

• Multiple measurements can be performed on the same 
image (e.g., disease infection area, percentage of disease 
infection, and leaf spot counts).

• Images themselves are very good visual data.

• Photographs can be saved with metadata, such as geolo-
cation, date, and time, automatically.

Disadvantages
• Image-based measurements cannot distinguish between 

different diseases and symptoms caused by different 
factors (e.g., disease vs. abiotic stress).

• Accuracy of measurements can be affected by the image 
quality and the severity of disease damage.

• Using ImageJ for image processing and analysis requires 
some basic computer literacy and the installation of a 
compatible version of Java software (https://www.java.
com/ES/download/).

How to Capture Ideal Images for 
Image Analysis
Obtaining high-quality images is critical to both qualitative 
interpretations and quantitative measurements via image 
analysis. High-quality images can also save a significant 
amount of time in image processing. Here are some tips to 
take ideal images for image analysis:

• Use a flatbed scanner instead of a camera. Scanned 
images have several advantages over photographs, 
including better color depth, uniform lighting, no optical 
distortion, and minimized leaf curvature effects. We 
recommend using a resolution of 300 dots per inch (dpi) 
or higher.

• If taking photographs indoors, use a tripod and lay leaves 
on a high-contrast background (e.g., white piece of paper, 
black sheet). Include a reference object of known size in 
the image, so the image can be scaled.

• If taking photographs outdoors, choose an overcast day, 
or a camera angle that can minimize deep shadows in the 

image (e.g., a sunny day with no clouds at 12–2 pm for 
overhead plot photographs).

Download ImageJ Software
The tutorial video for this step is available at https://youtu.
be/KMq4cV_BQ7Y.

1. Go to https://imagej.nih.gov/ij/ and select “Download.”

2. Determine your platform (Mac/Linux/Windows) and 
click on the appropriate link.

3. Install the program. The measurements described below 
do not require plugins.

Note:
• Another download option is Fiji (https://imagej.net/

Fiji/Downloads), a version of ImageJ bundled with 
many plugins.

• There are also other useful plugins available for 
separate download (e.g., Wika Segmentation for 
training ImageJ to automatically process images).

• The version of ImageJ used in this article is 1.52.

Set Scale (Image Size Calibration)
Photographs
The tutorial video for this step is available at https://youtu.
be/HoidaLxKMMk.

1. Import the image: Go to “File > Open” and navigate to 
the image or drag the file onto the ImageJ toolbar. Below 
is a photograph of blackberry leaves laid flat on a piece 
of white copy paper. The photograph was taken using a 
compact digital camera (SONY DSC-RX100) in a room 
with only ceiling lights.

https://www.java.com/ES/download/
https://www.java.com/ES/download/
https://youtu.be/KMq4cV_BQ7Y
https://youtu.be/KMq4cV_BQ7Y
https://imagej.nih.gov/ij/
https://imagej.net/Fiji/Downloads
https://imagej.net/Fiji/Downloads
https://youtu.be/HoidaLxKMMk
https://youtu.be/HoidaLxKMMk
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2. Select the “Straight Line” tool (highlighted below).

3. Draw a line to an object of known size (e.g., ruler).

4. Go to “Analyze > Set Scale” to set the distance to the line.

i) Enter the following parameters (e.g., ruler height = 5 
inches).

• Known distance: 5

• Unit of length: inch

• Global: Checked

ii) Click on “OK.”

Note:
• For accurate image size calibration, the reference 

object should be large and near the object of interest.

• When the “Global” option is checked, the same image 
calibration will be applied to images that will be 
imported subsequently. Use this option when the same 
image needs to be imported multiple times to perform 
different sets of image analysis or when all images in a 
set have the same scale (e.g., scanned images, images 
taken using a tripod). When working on an image 
with a different scale, “Set Scale” must be done again.

Scanned Images
The tutorial video for this step is available at https://youtu.
be/9vnIt0JXJ5M.

1. Obtain the pixel dimensions, resolution, and physical size 
of the image.

Note:
• On Windows, the image’s pixel dimensions and 

resolution in dots per inch (dpi) can be obtained by 
right-clicking the file, opening “Properties,” and then 
viewing the “Details” tab. To calculate the physical im-
age size, divide the pixel dimensions by the resolution.

• On Mac, the image’s physical size in inches, dpi, and 
pixel dimensions can be obtained by opening the file 
in “Preview” and going to “Tools > Adjust Size....”

2. Import the image in ImageJ. Below is a scanned image 
in 3400 × 4680 pixels at 400 dpi (8.5 × 11.7 inches) of 
a tomato leaf obtained using a flatbed scanner (Epson 
Perfection V800).

3. Go to “Analyze > Set Scale” to calibrate the image.

i) Enter the following parameters.

• Distance in pixels: 3400

https://youtu.be/9vnIt0JXJ5M
https://youtu.be/9vnIt0JXJ5M
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• Known distance: 8.5

• Unit of length: inch

• Global: Checked

ii) Click on “OK.”

Note:
• In ImageJ, pixel dimensions are listed on the left upper 

corner of the image window.

Area Measurement
Example 1: Blackberry Phomopsis Leaf 
Blight (Sampled Leaves)
The tutorial video for this step is available at https://youtu.
be/tvosUZh6oDI.

This example will use the photograph of the blackberry 
leaves used in the “Set Scale” section. Phompsis leaf blight is 
displayed as large necrotic lesions.

1. Go to “Image > Adjust > Color Threshold” to separate the 
leaf from the background.

i) Adjust color threshold parameters (hue, saturation, and 
brightness) to select the entire leaf (healthy + diseased).

Note:
• Hue is one of the color appearance parameters, and 

it describes pure spectrum colors. For the entire leaf 
area, the hue range from 0 to 110 works well for most 
images.

• The optimum values can vary depending on the image 
quality, particularly for saturation and brightness.

ii) Click on “Select.”

2. Go to “Process > Binary > Make Binary” to convert the 
color image to a binary (black and white) image.

https://youtu.be/tvosUZh6oDI
https://youtu.be/tvosUZh6oDI
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3. Use the “Paintbrush Tool” to remove large clusters of 
pixels that are not part of the leaves.

i) Double click the “Paintbrush Tool” (highlighted below).

ii) Select the following parameters.

• Brush width: 50

• Color: White

• Paint on overlay: Unchecked

iii)  Click on “OK” and erase the pixels that are not part of 
the leaves.

4. Go to “Process > Noise > Remove Outliers” to remove 
small specks that are not part of the leaves. This step can 
be skipped when the image has a clean background as in 
this example.

5. Select measurement variables and perform the measure-
ment of the entire leaf area.

i) Go to “Analyze > Set Measurements” and select “Area” 
and “Limit to threshold.”

ii) Click on “OK.”

iii)  Go to “Analyze > Measure” or Ctrl+M to measure the 
entire leaf area.

6. Reopen the same image and go to “Image > Adjust > 
Color Threshold” to select the diseased leaf area.
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i) Adjust color threshold parameters (hue, saturation, and 
brightness).

Note:
• The hue range from 0 to 40 works well to select the 

diseased leaf area in this image.

• The optimum hue range varies depending on the 
severity of chlorosis or necrosis and the greenness of 
the healthy leaf area.

ii) Click on “Select.”

7. Go to “Process > Binary > Make Binary” to convert the 
color image to a binary image.

8. Use the “Paintbrush Tool” to remove large clusters of 
pixels that are not necrotic lesions.

9. Go to “Process > Noise > Remove Outliers” to remove 
small specks that are not necrotic lesions.

i) Select the threshold as follows.

• Radius: 5

• Threshold: 50

• Which outliers: Dark

ii) Check on “Preview.” If everything looks good, click on 
“OK.”

Note:
• Increase the radius if outliers are not removed.

• Select the radius that can remove outliers without 
deleting a significant portion of lesions.
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10. Go to “Analyze > Measure” or Ctrl+M to measure the 
diseased leaf area.

11. Calculate the percentage of disease damage as follows: 
Diseased leaf area ÷ Entire leaf area × 100. Figure 1 
shows blackberry leaf images processed by ImageJ to 
measure the entire, healthy, and diseased leaf areas.

Example 2: Cucumber Downy Mildew 
(Multiple Plants)
The tutorial video for this step is available at https://youtu.
be/elyYvOEUezM.

This example will use a photograph of cucumber plants in 
the field. The photograph was taken using a compact digital 
camera (SONY DSC-RX100) in the middle of a sunny day. 
Damage caused by downy mildew is displayed as necrosis 
on the vines.

1. Import the image.

2. Go to “Image > Adjust > Color Threshold” to separate the 
canopy from the background.

i) Adjust color threshold parameters (hue, saturation, 
and brightness) to select the entire canopy (healthy + 
diseased).

Note:
• In this image, hue between 0 and 122, saturation 

between 58 and 255, and brightness between 9 and 
255 work well.

ii) Click on “Select.”

3. Go to “Image > Color > Color Picker” to set the back-
ground color to white.

i) Double-click the “B” in the CP window.

ii) The Background Color window opens. Fill 255 in all 
three cells in the Background Color window.

iii)  Click “OK” to close the Background Color window.

iv) Close the CP window.

Note:
• Now if the background is cleared, it will be white 

instead of black.

https://youtu.be/elyYvOEUezM
https://youtu.be/elyYvOEUezM
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4. Go to “Edit > Clear Outside” to remove everything but 
the selected area.

5. Use the “Paintbrush Tool” or “Process > Noise > Remove 
Outliers” to remove pixels that are not leaves.

6. Go to “File > Save As... > Tiff...” to save the image as a 
TIFF file. The saved image will be used in Steps 8–10 to 
measure the entire canopy area and in Steps 12–14 to 
measure the diseased canopy area.

7. Close the image window and open the image saved in 
Step 6.

8. Repeat Step 2 to select the canopy.

9. Go to “Process > Binary > Make Binary” to convert the 
color image to a binary image.

10. Go to “Analyze > Measure” or Ctrl+M to measure the 
entire canopy area.

11. Close the image window and reopen the image saved in 
Step 6.

12. Go to “Image > Adjust > Color Threshold” to select the 
diseased canopy area.

i) Adjust color threshold parameters (hue, saturation, and 
brightness).

Note:
• In this image, hue between 0 and 45, saturation 

between 0 and 155, and brightness between 0 and 254 
work well.

ii) Click on “Select.”
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13. Go to “Process > Binary > Make Binary” to convert the 
color image to a binary image.

14. Go to “Analyze > Measure” or Ctrl+M to measure the 
diseased canopy area.

15. Calculate the percentage of disease damage as follows: 
Diseased canopy area ÷ Entire canopy area × 100.

Count Measurement (Tomato 
Bacterial Leaf Spot)
Example 1: Scanned Image
The tutorial video for this step is available at https://youtu.
be/YV5L_YDMkRo.

This example will use the tomato leaf scan used in the “Set 
Scale > Scanned Images” section. Tomato bacterial leaf spot 
is displayed as small dots on the back of the leaf.

1. Click the “Rectangle” tool (highlighted below).

2. Select the smallest rectangle possible around the leaf.

3. Go to “Image > Crop.”

4. Go to “Image > Adjust > Color Threshold” to select leaf 
spots.

i) Adjust color threshold parameters (hue, saturation, and 
brightness).

Note:
• In this image, hue between 0 and 47, saturation 

between 0 and 255, and brightness between 0 and 147 
work well.

ii) Click on “Select.”

https://youtu.be/YV5L_YDMkRo
https://youtu.be/YV5L_YDMkRo
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5. Go to “Process > Binary > Make Binary” to convert the 
color image to a binary image.

6. Use the “Paintbrush Tool” to remove large clusters of 
pixels that are not leaf spots.

7. Go to “Process > Noise > Remove Outliers” to remove 
small specks that are not leaf spots.

i) Select the threshold as follows.

• Radius: 1

• Threshold: 50

• Which outliers: Dark

ii) Check on “Preview.” If everything looks good, click on 
“OK.”

Note:
• To avoid deleting leaf spots in this step, open the 

original image and compare it to the edited image.

8. Go to “Analyze > Analyze Particles” to measure the 
number of leaf spots.

i) Enter the following parameters.

• Size (unit^2): 0–Infinity.

• Circularity: 0.00–1.00

• Pixel units: Checked

• Show: Outlines

Note:
• Use the “Size” option to exclude pixels that are not leaf 

spots by size by setting the minimum and maximum 
pixel areas. In Steps 6–7, we removed all large and 
small particles that were not leaf spots. We can there-
fore count all remaining particles.

• Use the “Circularity” option to exclude pixels that are 
not leaf spots by roundness by setting the minimum 
and maximum circularity. Zero is not round at all and 
1 is a perfect circle.
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• The “Show” option provides multiple possible visual 
outputs.

ii) Select the options checked in the image below.

iii)  Click on “OK.”

9. Record the desired information from the “Summary” and 
“Results” tables. The count data are indicated by a red 
arrow in the image below.

Example 2: Field Photograph
The tutorial video for this step is available at https://youtu.
be/bDuj4Jl1OS8.

In this example, we will analyze a photograph of the same 
leaf from Example 1, taken in the field with a smartphone 
(iPhone 7). Because leaf curling has rendered some spots 
invisible and outdoor lighting has decreased the color 
contrast between the healthy leaf tissue and the diseased 
tissue, ImageJ will detect fewer leaf spots in the photograph 
than in the scanned image. However, it is still possible to 
count leaf spots using the following procedure.

1. Import the image.

2. Use the “Freehand selections” tool to select the area of 
interest.

i) Click the “Freehand selections” tool (highlighted 
below).

ii) Left-click and hold to start outlining.

iii) While continuing to hold, outline the entire desired 
area.

https://youtu.be/bDuj4Jl1OS8
https://youtu.be/bDuj4Jl1OS8
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Note:
• For most consistent results, it may be necessary to 

standardize what part of the leaf to select. In this 
image, diseased tissues on the border of the leaf have 
been excluded.

3. Go to “Edit > Clear Outside” to remove the background.

4. Go to “Image > Adjust > Color Threshold” to select leaf 
spots.

i) Adjust color threshold parameters (hue, saturation, and 
brightness).

Note:
• In this image, hue between 0 and 47, saturation 

between 0 and 255, and brightness between 0 and 254 
work well.

ii) Click on “Select.”

5. Go to “Process > Binary > Make Binary” to convert the 
color image to a binary image.

6. Use the “Paintbrush Tool” to remove large clusters of 
pixels that are not leaf spots.

7. Go to “Process > Noise > Remove Outliers” to remove 
small specks that are not leaf spots.

i) Select the threshold as follows.

• Radius: 2

• Threshold: 50

• Which outliers: Dark

ii) Check on “Preview.” If everything looks good, click on 
“OK.”
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8. Go to “Analyze > Analyze Particles” to measure the 
number of leaf spots.

i) Enter the following parameters.

• Size (unit^2): 0–Infinity.

• Circularity: 0.00–1.00

• Pixel units: Checked

• Show: Outlines

ii) Check the same options selected in the same step for 
Example 1.

iii)  Click on “OK.”

9. Record the desired information from the “Summary” and 
“Results” tables. The count data are indicated by a red 
arrow in the image below.
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