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1. INTRODUCTION 
 

Passive microwave signatures have been used to retrieve geophysical parameters, such as soil 
temperature [Njoku and Li, 1999], moisture [Jackson et al., 1995], and surface roughness [Wegmüller and 
Mätzler, 1999]. One of the challenges in the parameter retrieval is the effect of soil surface roughness on the 
microwave emission. We conducted soil surface roughness measurements as part of our fourth Microwave 
Water and Energy Balance Experiment (MicroWEX-4) to understand the effects of surface roughness on 
microwave signatures at 6.7 GHz (λ = 4.48 cm). The dataset will also be used to develop and validate 
surface roughness models. In this report, we summarize briefly the theoretical background of surface 
roughness characteristics and discuss methodology and results of the roughness experiments. 

 
 

2. SOIL SURFACE STATISTICS 
 

Soil surface can be characterized mainly by three parameters; the standard deviation of surface height 
(rms height, σ), the surface correlation length (l), and the auto correlation function (ACF). The rms height 
describes random surface characteristics, while the correlation length and the correlation function describe 
periodicity of the surface (Ulaby et al., 1982). Figures 1(a) and (b) show random height variations 
superimposed on either a periodic or a flat surface.  

 

 
(a) 

 
(b) 

 
Figure 1. Random height variations superimposed on a (a) periodic surface (b) flat surface. 

 
2.1 Standard Deviation of Surface Height (RMS height) 
In terms of the mean surface height ( z ) and the second moment ( 2z ), the rms height, σ, is then given by  

 

( ) 2122 zz −=σ ,        (1) 
 
For a one-dimensional surface profile, σ is computed by digitizing the profile into discrete values,  zi(xi), at 
an appropriate horizontal spacing, Δx. If the height variation, Δz, corresponding to a Δx is much smaller than 
the wavelength, λ, of the incident wave, the variation will have no effect on the reflection from the surface 
of Δx. Typically, Δx ≤  0.1 λ. The standard deviation σ for the discrete one-dimensional case is given by, 
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where N is the number of samples and  
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2.2 Surface Correlation Length (l) and Autocorrelation Function (ACF) 
A surface autocorrelation curve is used to determine the correlation length and the autocorrelation function 
(ACF). The autocorrelation is a measure of the similarity between the height, z(x), at a point x and the 
height, z(x+x'), at a point x+x'. The normalized ACF, ρ(x´), for a one-dimensional surface profile of length, 
L, is defined as, 
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For a discrete case, ρ(x´) for x' = (j-1) Δx, where j is an integer ≥ 1, is given by 
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The correlation length, l, is the displacement, x,' for which ρ(x') = 1/e: 

el /1)( =ρ         (6) 
 
It is used to fit a theoretical correlation function, such as exponential or gaussian, to the measured 
autocorrelation curve by optimizing the power coefficient (n). The ACF is mathematically represented by, 

( ) n

l
xx ′=′ exp)(ρ        (7) 

 
where n describes the correlation function. For example, n=1 for an exponential ACF and n=2 for a 
gaussian ACF. 
 

3. SURFACE ROUGHNESS MEASUREMENTS 
 

3.1 Field Setup 
Soil surface roughness measurements were conducted by the Center for Remote Sensing, Agricultural and 
Biological Engineering Department, at the Plant Science Research and Education Unit (PSREU), IFAS, 
Citra, FL, as the part of the Fourth Microwave Water and Energy Balance Experiment (MicroWEX-4) 
[Casanova et al., 2005]. Roughness was measured weekly from April 18 to June 13 in 2005, during the 
corn-growing season. Figure 2 shows the field site and the three regions of the field used for roughness 
measurements: The eastern region that was very rough, the western region that was very smooth, and the 
radiometer footprint area that was of intermediate roughness. The figure also shows four profile directions 
used for the measurements: Parallel and perpendicular to the row direction and to the radiometer look 
direction. Table 1 shows the sampling dates and events of the measurements. A total of 62 soil surface 
profiles were measured during the experiment. 
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Figure 2. Three sites and four profile directions for the soil surface roughness measurements. 

 
Table 1. Schedule of surface roughness measurements 
Near the radiometer East (very rough) West (very smooth) DAY 

(DoY) Direction Time Comment Time Comment Time Comment 
1 12:30 p.m.  N  N  
2 12:20 p.m.  N  N  
3 N  N  N  

Apr. 18 
(108) 

4 N  N  N  
1 3:00 p.m.  3:10 p.m. C 3:20 p.m.  
2 3:00 p.m.  3:10 p.m. C 3:20 p.m.  
3 N  N  N  

May 1 
(121) 

4 N  N  N  
1 4:20 p.m.  4:30 p.m.  5:00 p.m.  
2 4:20 p.m.  4:30 p.m.  5:00 p.m.  
3 4:25 p.m.  4:40 p.m.  5:00 p.m.  

May 8 
(128) 

4 4:25 p.m.  4:40 p.m.  5:00 p.m.  
1 1:50 p.m.  1:40 p.m.  2:00 p.m.  
2 1:50 p.m.  1:40 p.m.  2:00 p.m.  
3 1:50 p.m.  1:40 p.m.  2:00 p.m.  

May 12 
(132) 

4 1:50 p.m.  1:40 p.m.  2:00 p.m.  
1 12:00 p.m.  12:20 p.m.  1:10 p.m.  
2 12:00 p.m.  12:20 p.m.  1:10 p.m.  
3 12:00 p.m.  12:20 p.m.  1:10 p.m.  

May 20 
(140) 

4 12:00 p.m.  12:20 p.m.  1:10 p.m.  
1 11:30 p.m.  12:00 p.m.  12:30 p.m.  
2 11:30 p.m.  12:00 p.m.  12:30 p.m.  
3 11:30 p.m.  12:00 p.m.  12:30 p.m.  

May 26 
(146) 

4 11:30 p.m.  12:00 p.m.  12:30 p.m.  
1 N R 2:00 p.m.  2:15 p.m.  
2 N R 2:00 p.m.  2:15 p.m.  
3 N R 1:50 p.m.  2:10 p.m.  

June 6 
(157) 

4 N R 1:50 p.m.  2:10 p.m.  
1 3:50 p.m. F N R N R 
2 3:50 p.m. F N R N R 
3 4:00 p.m. F N R N R 

June 13 
(164) 

4 4:00 p.m. F N R N R 
1. Parallel to the row direction  
2. Perpendicular to the row direction 
3. Parallel to the radiometer look direction (N-S) 
4. Perpendicular to the radiometer look direction (E-W) 

N   No measurement 
R   Heavy Rain 
F   In the footprint 
C   In the clay region of the East side 
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3.2 Measurement Methodology 
Soil surface height was measured using a 2.14 m X 0.9 m metal mesh-board, as shown in Figure 3. The 
board was marked at intervals of 2 cm for the accurate sampling. A picture was taken using a digital camera 
and scanned. Each picture was digitized using the SigmaScan Pro5 software, with distance on the x-axis and 
height on the y-axis. The digitization followed one of the two methods described by [Jackson et al., 2004]. 
We took a height measurement at every point where the slope of the surface changed or at least at every 1-
cm interval. Thus, for our 2.14 m long mesh-board, each digitized picture yields 214 data points, provided 
there were no missed sampling point. Detailed protocol of using the Sigmascan Pro5 software is described 
in Appendix A. 

 
 

 
Figure 3. A 2.14 m long metal mesh-board 

 
3.3 Roughness Parameter Calculation 
The roughness parameters, σ, l, and ACF, were calculated using an EXCEL spread sheet, enabled with 
Marcos, as shown in Appendix B (Dr. M. Cosh, personal communication, 2005). The program interpolated 
the digitized surface profiles and computed the roughness parameters. It also corrected for the slope of the 
roughness board using a ‘least square’ fit and calculated an adjusted σ. For our case, with, we selected. The 
program was applied to our 64 profiles, using Δx=1 mm (for our case, λ = 4.5cm). The interpolated soil 
surface profiles are shown in Figure 4 (a-c). The σ and l are shown in Table 2. Figures 5 (a-f) show the 
measured ACFs compared with the Gaussian and the Exponential correlation functions.  
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(a) 

 
(b) 

 
(c) 

Figure 4. Digitized soil surface profiles for (a) near the radiometer footprint (R), (b) at the East site (E), and (c) the West site 
(W). 1 to 4 represent parallel and perpendicular to the row direction and the radiometer look direction, respectively. 
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Table 2. Measured soil surface roughness parameters 

Near the radiometer East (very rough) West (very smooth) DAY 
(DoY) Direction rms height 

(mm) 
Correlation 
length (mm) 

rms height 
(mm) 

Correlation 
length (mm) 

rms height 
(mm) 

Correlation 
length (mm) 

1 7.9 92.0 - - - - 
2 16.4 147.0 - - - - 
3 - - - - - - 

Apr. 18 
(108) 

4 - - - - - - 
1       
2       
3 - - - - - - 

May 1 
(121) 

4 - - - - - - 
1 7.0 265.1 4.8 246.5 7.0 275.6 
2 7.2 205.0 11.2 180.5 2.4 73.5 
3 4.8 204.8 8.4 219.2 6.2 204.9 

May 8 
(128) 

4 10.2 218.7 9.7 149.3 3.0 140.1 
1 6.1 226.7 4.6 275.7 5.2 291.1 
2 9.6 145.4 9.4 161.6 2.2 88.0 
3 6.2 268.7 5.5 230.5 3.9 252.8 

May 12 
(132) 

4 11.3 282.4 10.4 169.4 3.3 142.7 
1 4.5 147.0 1.9 307.6 4.9 204.4 
2 7.1 212.4 18.3 261.0 5.5 212.8 
3 6.6 155.9 6.3 281.6 3.9 294.9 

May 20 
(140) 

4 6.9 190.6 18.5 233.0 4.1 240.1 
1 3.2 79.9 5.4 160.2 4.5 200.5 
2 17.4 285.8 12.8 175.0 4.5 122.0 
3 6.0 195.8 16.6 223.6 4.5 329.7 

May 26 
(146) 

4 15.4 189.7 19.9 228.9 7.1 237.3 
1 - - 3.1 355.2 4.4 218.6 
2 - - 9.6 131.8 5.6 275.7 
3 - - 8.7 309.2 2.8 94.2 

June 6 
(157) 

4 - - 9.7 149.8 3.2 244.8 
1 6.6 231.1 - - - - 
2 8.9 237.2 - - - - 
3 7.5 366.5 - - - - 

June 13 
(164) 

4 9.2 225.7 - - - - 
 

1. Parallel to the row direction     3. Parallel to the radiometer look direction (N-S) 
2. Perpendicular to the row direction   4. Perpendicular to the radiometer look direction (E-W) 
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(a) 
 

 
(b) 

 
Figure 5. Measured ACF compared with Gaussian and Exponential (a) April 18 (DOY 108), (b) May 8 (DOY 128). R, E and W 
represent near the radiometer, at the East site and the West site, respectively; and 1 to 4 represent parallel and perpendicular to the 
row direction and the radiometer look direction, respectively. 
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(c) 
 

 
(d) 

Figure 5 (contd). (c) May 12 (DOY 132) (d) May 20 (DOY 140). 
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(e) 

 

 
(f) 
 

Figure 5 (contd). (e) May 26 (DOY 146) and (f) June 13 (DOY 164). 
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6. APPENDIX 

 
A. SigmaScan Pro5 Software Protocol 
 
1) Start SigmaScan Pro 5 
 

 
 
 
2) Select File>Open>Image. Click on the image to be processed and then click Open. Click View>Zoom 

Out to achieve the proper image display on the window. 
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3) Select Image>Calibrate>Distance and Area and click on 3 Point-Calibration. On the Uncalibrated [X,Y] 
are the coordinates of the original image coordinates, whose default values are [0,0],[100,0], and 
[100,100] for point 1, 2, and 3 respectively. On the Calibrated [X,Y] are the coordinates of the image 
based on the grid point coordinates, whose default values are [0,0],[100,0], and [100,100] for point 1, 2, 
and 3, respectively.  

4) Use the mouse pointer to select the points at the (1) far left, (2) far right, and (3) center of the grid 
board coordinates in the image (as shown in the figure). The coordinates in the Uncalibrated [X,Y] will 
change to the points that are selected. Type in coordinates of the three selected points corresponding to 
the grid point coordinates and click OK. 
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5) Select Measurement>Settings, in Measurements window select only the last two options x and y of 
measurement type Point as Column A and B and click OK. 

 

 
 

6) Select Mode>Trace Measurement Mode 
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7) Start from the left of the soil surface profile. The first point is where the soil surface intersects the grid at 
(0,Y). Click on the point at the soil surface profile every 1 cm in the image to the last point possibly seen 
in the image (The grid board of the example is 3 by 3 cm, e.g. 2 points between the grids). Note that a 
worksheet will pop up once the first point is selected. 

 

 
 
 
8) Click on the worksheet once the last point is selected. Then select File>Save, to save the coordinates into 

an Excel file and close SigmaScan. 
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B. EXCEL Spreadsheet for Roughness Calculations 
 
1) Open the EXCEL file Surface_Roughness_Calc.xls. Enable Marcos. 
 

 
 
 
2) Open the digitize soil surface profile saved by the Sigmascan and copy the Column A and B to the 

Column A and B in the Surface_Roughness_Calc.xls. 
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3) Click “compute roughness” to calculate the roughness parameters. The number of sampling points is 
shown in Column D Row 1. The root mean square height (σ), autocorrelation length (l), and slope-
corrected root mean square height (σadj) are listed in Column D Row 2, 3, and 4, respectively. 
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4) There are two methods to determine the power coefficient. The first method is to interpret it from the 
distance vs. autocorrelation plot. The bold red curve is the measurement. Choose the closet curve to the 
measured curve. The second method is to observe the values in Columns J through T and Rows 1 and 2. 
The values in Columns J through T in Row 1 are the measurements. The values in Columns J through T 
in Row 2 are the theoretically derived values. If the measurement curve fits between the Gaussian and 
Exponential distributions, one of the measurement values will be equal to zero (i.e. one of the values in 
Columns T through J in Row 1 will be zero). Otherwise, choose the closest distribution. For example, 
the following figure shows the measurement curve is not within the range of Gaussian and Exponential. 
However, the decrease in measurement values is closer to Gaussian instead of Exponential. In this case, 
the power coefficient (n) (see equation 7) will be 1.5. 

 

 
 
 

5) Open a blank Excel spread sheet. In the first row, type in File Name, Num of Pts, Sigma, L, Sigma Adj, 
and n in Column A, B, C, D, E, and F respectively. The File Name will be the name of the raw 
roughness image. Fill in the values calculated by Surface_Roughness_Calc.xls in the corresponding 
spaces.  
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